[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSD/4.0/DST' instead
[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: getdate(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSD/4.0/DST' instead
SolaraGuy.com • View topic - need advice. rear strut mounts
Talk about aftermarket Toyota Solara Gen 1-1.5 upgrades.

need advice. rear strut mounts

need advice. rear strut mounts

Postby corlon » Thu Jun 07, 2012 10:52 pm

going to be installing tokico rear struts with existing factory springs. i plan on replacing the strut mounts. does anyone have input as to what brand has worked for them. oem, off brand, etc?
NiCe
User avatar
corlon
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 788
Joined: Mon Nov 26, 2007 11:26 pm
Location: midwest

Re: need advice. rear strut mounts

Postby PlateLunch » Fri Jun 08, 2012 10:21 am

I used the Monroe ones, got 'em from autoparts wherehouse and they are working great for me. Pretty cheap from what I can remember.
User avatar
PlateLunch
Regular SolaraGuy Member
Regular SolaraGuy Member
 
Posts: 210
Joined: Tue Aug 16, 2011 11:00 pm
Location: Wa.

Re: need advice. rear strut mounts

Postby TheGreenDutch » Fri Jun 08, 2012 10:42 am

I've had ebay ones on for almost 2 years so far so good. You can buy them at the local auto parts store. Pretty much all the same if its not OE
User avatar
TheGreenDutch
Regular SolaraGuy Member
Regular SolaraGuy Member
 
Posts: 235
Joined: Thu May 20, 2010 9:55 am
Location: PHILLY

Return to Aftermarket Gen1 and 1.5

Who is online

Users browsing this forum: No registered users and 5 guests