[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSK/3.0/no DST' instead
[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: getdate(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSK/3.0/no DST' instead
SolaraGuy.com • View topic - Torque Rod Installation
Non-tutorials will be deleted.

Torque Rod Installation

Postby Astro » Wed Apr 20, 2005 10:22 am

SleeperSolara wrote:Looks good.
Where can i get one??

Contact:
Jim @ Foreign Affairs
503-236-2871
ImageImage
Lexus lip kit, LED tails, F-Sport Intake, HKS hi-power exhaust, TEIN S-tech springs
User avatar
Astro
SolaraGuy Professional Racer
SolaraGuy Professional Racer
 
Posts: 4553
Joined: Wed May 14, 2003 11:33 pm
Location: Sherman Oaks, CA

Postby SleeperSolara » Thu Apr 21, 2005 7:06 am

He doesn't have a website??
I guess
2000 Solara SE auto V6. Diamond White Pearl.
Top Speed Run finished at 130 mph. :o
Too many modifcations for the signature.
User avatar
SleeperSolara
SolaraGuy Hall of Famer
SolaraGuy Hall of Famer
 
Posts: 9257
Joined: Tue Jun 15, 2004 11:38 am
Location: The 405

Postby Paladin06Greg » Thu Apr 21, 2005 8:11 am

Jim does have a web-site. Go here.
http://www.camryman.org/

SleeperSolara wrote:He doesn't have a website??
I guess
Paladin06Greg
Torqued Solara
Torqued Solara
 
Posts: 3056
Joined: Tue Mar 09, 2004 2:19 pm
Location: East Valley AZ, USA

Postby SleeperSolara » Fri Apr 22, 2005 7:41 am

Thanks his forum look just like SolaraGuy.com
2000 Solara SE auto V6. Diamond White Pearl.
Top Speed Run finished at 130 mph. :o
Too many modifcations for the signature.
User avatar
SleeperSolara
SolaraGuy Hall of Famer
SolaraGuy Hall of Famer
 
Posts: 9257
Joined: Tue Jun 15, 2004 11:38 am
Location: The 405

Postby Fletch » Sat Apr 30, 2005 7:02 am

Has anybody else noticed a slight clicking sound with the torque of the engine during take off? My guess is may be the ball joint to the lower mount bolt but I haven't had a chance to root cause it yet.

My y-pipe is also mounted very rigidly so it may be hard contact with something.

Thanks.
2006 Legacy GT spec.B

(Totaled) '99 SE V6, TRD S/C, 5.5 psi Pulley, Jim's Fuel Upgrade, TRD Shortshifter, SPEC Stage 3 Clutch, Lightweight Flywheel, Tokico / Eibach, TRD RSB, 2.5" Custom Y-Pipe, Greddy Cat-Back
Fletch
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 693
Joined: Wed May 14, 2003 1:03 pm
Location: South Bend, Indiana

Postby that1mexguy » Tue May 17, 2005 5:57 pm

Ok so i got my Fuel upgrade and torque rod upgrades today (thanks Jim!!) and honestly, i had no idea what to expect with the torque rod upgrade. I followed the instructions above (so easy, thanks Joe) and I think i got it. Only question I have is, i tighten up the bolts as much as i could, but the bottom part (part "C" on pic one) seems to still move around from left to right no matter how tight i'd do the bolts, is that normal??? other than that, as i had just mentioned, i had no idea what to expect so I took it for a test drive and the one thing i noticed is that shifting, specially at taking off, was sooooooooooo smooooth ... so i'm guessing that is what the torque rod was supposed to do? or was it just my imagination?? anyway, i got a stock torque rod if anybody wants one LOL
that1mexguy
SolaraGuy Supporter
SolaraGuy Supporter
 
Posts: 2454
Joined: Fri Nov 01, 2002 4:44 pm
Location: Atl, GA

Postby Nyyankees3511 » Sun Jan 29, 2006 11:52 am

Sorry to bring an old post back, but i just put my torque rod it and from the pics i see, on mine theres isnt that much rod coming out from the top bolt? Could it be my engine is leaning back? Also the bottom that connects to the body doesnt move at all, and by what Jim said, it shouldnt be in tension.
1999 SLE Red metallic/black interior
TRD RSB, Jim's Torque rod, K&N, Interior leds
Nyyankees3511
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 942
Joined: Wed Sep 07, 2005 5:31 pm
Location: Lincoln, RI

Postby Paladin06Greg » Sun Jan 29, 2006 12:11 pm

You need to adjust the rod ends.

Nyyankees3511 wrote:Sorry to bring an old post back, but i just put my torque rod it and from the pics i see, on mine theres isnt that much rod coming out from the top bolt? Could it be my engine is leaning back? Also the bottom that connects to the body doesnt move at all, and by what Jim said, it shouldnt be in tension.
Paladin06Greg
Torqued Solara
Torqued Solara
 
Posts: 3056
Joined: Tue Mar 09, 2004 2:19 pm
Location: East Valley AZ, USA

Postby Nyyankees3511 » Sun Jan 29, 2006 12:14 pm

It fits fine, it just looks like my engine is leaning to the compartment. How about the tension?
1999 SLE Red metallic/black interior
TRD RSB, Jim's Torque rod, K&N, Interior leds
Nyyankees3511
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 942
Joined: Wed Sep 07, 2005 5:31 pm
Location: Lincoln, RI

Postby Paladin06Greg » Sun Jan 29, 2006 12:52 pm

It may appear to lean that should be ok. Setting the tension is your call. I have mine set just loose enough that there is slight movement by hand on the bottom rod end. Some people tighten it all the way down.

Nyyankees3511 wrote:It fits fine, it just looks like my engine is leaning to the compartment. How about the tension?
Paladin06Greg
Torqued Solara
Torqued Solara
 
Posts: 3056
Joined: Tue Mar 09, 2004 2:19 pm
Location: East Valley AZ, USA

Postby Nyyankees3511 » Sun Jan 29, 2006 12:56 pm

Thanks Greg.
1999 SLE Red metallic/black interior
TRD RSB, Jim's Torque rod, K&N, Interior leds
Nyyankees3511
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 942
Joined: Wed Sep 07, 2005 5:31 pm
Location: Lincoln, RI

Postby solaraluv » Sun Jan 29, 2006 1:17 pm

please excuse my ignorance but what does it do?
Loved by few hated by many
solaraluv
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 288
Joined: Mon Nov 29, 2004 6:19 pm
Location: Boston, Massachusettes

Postby Paladin06Greg » Sun Jan 29, 2006 1:57 pm

Lessens the amout of motor movement when you accelerate thus allowing more torque/power to the wheels.

solaraluv wrote:please excuse my ignorance but what does it do?
Paladin06Greg
Torqued Solara
Torqued Solara
 
Posts: 3056
Joined: Tue Mar 09, 2004 2:19 pm
Location: East Valley AZ, USA

Postby Nyyankees3511 » Sun Jan 29, 2006 2:07 pm

Greg, you think it lowers your 0-60 and 1.4 times? I tightened it down more but i hear a clunk when i hit the gas after i put it in reverse and back into drive, just one clunck.
1999 SLE Red metallic/black interior
TRD RSB, Jim's Torque rod, K&N, Interior leds
Nyyankees3511
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 942
Joined: Wed Sep 07, 2005 5:31 pm
Location: Lincoln, RI

Postby Paladin06Greg » Sun Jan 29, 2006 2:42 pm

Don't know for sure. Better check your adjustment if you got a clunk :lol: .

Nyyankees3511 wrote:Greg, you think it lowers your 0-60 and 1.4 times? I tightened it down more but i hear a clunk when i hit the gas after i put it in reverse and back into drive, just one clunck.
Paladin06Greg
Torqued Solara
Torqued Solara
 
Posts: 3056
Joined: Tue Mar 09, 2004 2:19 pm
Location: East Valley AZ, USA
PreviousNext

Return to Tutorials Gen 1 and 1.5

Who is online

Users browsing this forum: No registered users and 2 guests