[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSD/4.0/DST' instead
[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: getdate(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSD/4.0/DST' instead
SolaraGuy.com • View topic - VSC,TRAC,CEL
Stock talk about the Generation 2 and 2.5 Toyota Solara which was released in 2004-2007

VSC,TRAC,CEL

VSC,TRAC,CEL

Postby NightRider » Thu Apr 15, 2010 7:38 pm

So I am driving home from work and I see these three lights on in my dash and I'm like WTF!? So I check the electrical stuff and they work fine. I get home and check the fuses and they are ok. So I reset the ECU and of course the lights are gone. So I'll see what happens when I drive to work tomorrow and see if they turn on again :(

In the meantime can someone enlighten me on to what it can or could be!?I'm a bit worried and affriad that it could be something major and costly.
Image
2004 Black Solara V6SLE COUPE
5% rear window tint 20% front window tint
Injen polished SRI
Alpine Deck w/ complete Rocksford Fosgate speakers & subs
TRD FSB 6000K HID's
NightRider
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 555
Joined: Mon May 07, 2007 12:25 am
Location: East Bay to the Central Valley

Postby JavaJoe_2 » Thu Apr 15, 2010 8:33 pm

You have to pull the codes from the ecu. Often times a mil(cel) light will cause the vcs/trac lights to also come on.
The get back to us.
Got Boost?? :sweet:
JavaJoe_2
SolaraGuy Street Racer
SolaraGuy Street Racer
 
Posts: 1070
Joined: Fri Aug 20, 2004 7:21 am

Postby NightRider » Fri Apr 16, 2010 12:51 am

What's a mil(cel)?
Image
2004 Black Solara V6SLE COUPE
5% rear window tint 20% front window tint
Injen polished SRI
Alpine Deck w/ complete Rocksford Fosgate speakers & subs
TRD FSB 6000K HID's
NightRider
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 555
Joined: Mon May 07, 2007 12:25 am
Location: East Bay to the Central Valley

Postby gasolara2002 » Fri Apr 16, 2010 2:00 am

MAF sensor or EGR valve sensor is my guess. I know it happened to me and my egr valve sensor was bad.
White 02 Solara with retrofit; White 97 Land Cruiser with mods coming.

www.cardomain.com/ride/2398488
gasolara2002
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 559
Joined: Sat May 27, 2006 8:04 pm
Location: Clinton, Mississippi

Postby JavaJoe_2 » Fri Apr 16, 2010 4:38 am

NightRider wrote:What's a mil(cel)?


Same as the cel you are talking about.
mil= malfunction indicator light
cel=check engine light
Got Boost?? :sweet:
JavaJoe_2
SolaraGuy Street Racer
SolaraGuy Street Racer
 
Posts: 1070
Joined: Fri Aug 20, 2004 7:21 am

Postby Biggi_e » Fri Apr 16, 2010 7:39 am

it is your maf sensor. i just worked on my car yesterday and had the same codes. check to see if your maf sensor is getting enough power to it.
Biggi_e
SolaraGuy Semi-Pro Racer
SolaraGuy Semi-Pro Racer
 
Posts: 3279
Joined: Sun Jul 03, 2005 11:07 am
Location: G-burg, Murdaland

Postby NightRider » Fri Apr 16, 2010 9:27 am

My car has 87K and I had the intake on it for a while and I clean the air filter often. So just check the maf sensor? Could cleaning it possibly fix the issue?

And I drove to work this morning over 30+ miles and no lights on. Will see whats up when I drive home.
Image
2004 Black Solara V6SLE COUPE
5% rear window tint 20% front window tint
Injen polished SRI
Alpine Deck w/ complete Rocksford Fosgate speakers & subs
TRD FSB 6000K HID's
NightRider
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 555
Joined: Mon May 07, 2007 12:25 am
Location: East Bay to the Central Valley

Postby GzNutz » Fri Apr 16, 2010 3:47 pm

If you're reoiling the fliter after cleaning you may be getting a film on the maf from excess oil when driving. Cleaning the maf couldn't hurt, and could possibly be the cheapest fix.
User avatar
GzNutz
SolaraGuy Semi-Pro Racer
SolaraGuy Semi-Pro Racer
 
Posts: 2354
Joined: Mon Oct 22, 2007 7:36 pm
Location: Land of Beer

Postby Down2TheC » Fri Apr 16, 2010 4:14 pm

Yup, TRAC and VSC get shut off by the ECU for some of the other errors. So don't let those throw you.
No harm in swinging by a parts place for a free OBD reading. (AutoZone? Trak? Forget who does that.) Then at least you're not chasing a phantom.
http://solara.down2thec.com/gallery/
"We need failures in this world... failures gives us lap dances and chicken nuggets and I like both."
User avatar
Down2TheC
SolaraGuy Moderator
SolaraGuy Moderator
 
Posts: 3711
Joined: Sat Dec 25, 2004 12:03 am
Location: Chicago area

Postby NightRider » Fri Apr 16, 2010 7:17 pm

@Gznutz- yeah I always use the oil to coat the filter after I clean it. Yeah good suggestion, won't hurt to clean the MAF and it is the cheapest fix.

@ dwn2- yeah I suppose if they come back I would go get the OBD readings. Thanks for your help I appreciate it!

And the follow up from earlier I drove home from work and no CEL's but i am still going to clean the MAF.

-Richard
Image
2004 Black Solara V6SLE COUPE
5% rear window tint 20% front window tint
Injen polished SRI
Alpine Deck w/ complete Rocksford Fosgate speakers & subs
TRD FSB 6000K HID's
NightRider
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 555
Joined: Mon May 07, 2007 12:25 am
Location: East Bay to the Central Valley

Postby Sparky5e » Fri Apr 16, 2010 10:03 pm

before you respond...yes I tried the search function, otherwise known as POS.

What is used to clean the MAF Sensor without damaging it?
07 SLE Convertable
Blue Streak Metallic
TRD FSTB and RSB, OSB Pedals, OEM Nav, CPE Intake, Stainless sills, "color matching" floor mats
User avatar
Sparky5e
Regular SolaraGuy Member
Regular SolaraGuy Member
 
Posts: 151
Joined: Sun May 06, 2007 7:10 am
Location: IL

Postby NightRider » Fri Apr 16, 2010 10:07 pm

You can use throttle body cleaner
Image
2004 Black Solara V6SLE COUPE
5% rear window tint 20% front window tint
Injen polished SRI
Alpine Deck w/ complete Rocksford Fosgate speakers & subs
TRD FSB 6000K HID's
NightRider
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 555
Joined: Mon May 07, 2007 12:25 am
Location: East Bay to the Central Valley

Postby JavaJoe_2 » Sat Apr 17, 2010 5:41 am

Sparky5e wrote:before you respond...yes I tried the search function, otherwise known as POS.

What is used to clean the MAF Sensor without damaging it?



http://www.solaraguy.com/viewtopic.php?t=36189
Got Boost?? :sweet:
JavaJoe_2
SolaraGuy Street Racer
SolaraGuy Street Racer
 
Posts: 1070
Joined: Fri Aug 20, 2004 7:21 am

Postby Sparky5e » Sat Apr 17, 2010 10:10 am

Thanks guys.

Joe...thanks for the link I couldn't find :D
07 SLE Convertable
Blue Streak Metallic
TRD FSTB and RSB, OSB Pedals, OEM Nav, CPE Intake, Stainless sills, "color matching" floor mats
User avatar
Sparky5e
Regular SolaraGuy Member
Regular SolaraGuy Member
 
Posts: 151
Joined: Sun May 06, 2007 7:10 am
Location: IL

Postby NightRider » Sun Apr 18, 2010 10:37 pm

So I check my MAF sensor earlier and the little glass tip with wires was dirty. The side that faces where the air hits had this dirty oily film over it and the other side of it was clear from the oil and dirt. So I cleaned it and hopefully that solved the problem. I will keep you guys posted if this worked not.
Image
2004 Black Solara V6SLE COUPE
5% rear window tint 20% front window tint
Injen polished SRI
Alpine Deck w/ complete Rocksford Fosgate speakers & subs
TRD FSB 6000K HID's
NightRider
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 555
Joined: Mon May 07, 2007 12:25 am
Location: East Bay to the Central Valley
Next

Return to Stock Gen 2 and 2.5

Who is online

Users browsing this forum: Google [Bot] and 4 guests