[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSK/3.0/no DST' instead
[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: getdate(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSK/3.0/no DST' instead
SolaraGuy.com • View topic - 99---> 03 o2 Sensor discrepancies!
Stock talk about Solara

99---> 03 o2 Sensor discrepancies!

99---> 03 o2 Sensor discrepancies!

Postby tapakidney » Mon Aug 29, 2011 2:59 pm

Hi all. I used to drive a 99 Solara. Did some research when my CEL came on and successfully replaced an o2 sensor. I bought 2 Denso 234-4622's at the time.

http://www.amazon.com/Denso-234-4622-Ox ... 843&sr=8-1

Well, I sold the 99 and attained an 03 Solara. When the familiar old CEL came on again, I was prepared with my extra 234-4622! I felt so lucky and smart to have bought a spare. Every part checker I used said the 234-4622 would also work in the 03 model, so I thought I was good. Repair time came, and I was wrong (or, the part checkers were wrong...) The plug on my 4622 does not fit Bank 2, sensor 1 (Error p0155). Seems a good match for that sensor is actually the 234-9021.

http://www.amazon.com/Denso-234-9021-Ox ... 853&sr=8-1

The plug seems to match, and my monstrous repair books seem to imply that that sensor needs to be an A/F sensor, not just a regular o2 sensor. A/F are basically advanced o2 sensors, correct?

So, a couple questions:

1) Is this the right sensor for Bank 2, Sensor 1?
2) Can my extra 234-4622 be used at all on my 03?
3) There are 3 sensors total on the 03 Solara, correct? Will I need 2 of the 234-9021's (B1S1 and B2S1) and 1 of something else? If so, which model?

Thanks in advance!
tapakidney
Just Licensed SolaraGuy
 
Posts: 5
Joined: Thu Oct 16, 2008 3:21 pm

Re: 99---> 03 o2 Sensor discrepancies!

Postby 1gSE » Mon Aug 29, 2011 3:12 pm

http://www.rockauto.com/catalog/x,carco ... ttype,5132

I'm guessing you have Cali spec car with a/f sensors
Image
GTO-Vararam/Kooks/Spintech/MGW-P/Tune-12.9 @108
Solara-M62 @ 5.5psi
User avatar
1gSE
SolaraGuy Semi-Pro Racer
SolaraGuy Semi-Pro Racer
 
Posts: 2050
Joined: Wed Apr 11, 2007 8:37 pm
Location: Abilene, TX

Re: 99---> 03 o2 Sensor discrepancies!

Postby tapakidney » Mon Aug 29, 2011 3:17 pm

Actually no, not Cali. But when I was at an Autozone looking at all they had, the only kind I found that matched the hookup was the more expensive, AF ones. Or are you saying my car may have been built as Cali spec and will only take the AF sensors? Is there some way around this?

This one won't fit, because of that vertical center plastic bit:
http://www.rockauto.com/catalog/moreinfo.php?pk=2787768

This connector will fit:
http://www.rockauto.com/catalog/moreinfo.php?pk=870721

Am I missing something? Am I as limited by these connectors as i think I am?
tapakidney
Just Licensed SolaraGuy
 
Posts: 5
Joined: Thu Oct 16, 2008 3:21 pm

Re: 99---> 03 o2 Sensor discrepancies!

Postby 1gSE » Mon Aug 29, 2011 3:33 pm

Yeah thats exactly what I'm saying. California emissions cars have a/f sensors while federal spec used 02 sensors. Do you have pre-cats like this? viewtopic.php?p=382208

AFAIK, there's no way around it.
Image
GTO-Vararam/Kooks/Spintech/MGW-P/Tune-12.9 @108
Solara-M62 @ 5.5psi
User avatar
1gSE
SolaraGuy Semi-Pro Racer
SolaraGuy Semi-Pro Racer
 
Posts: 2050
Joined: Wed Apr 11, 2007 8:37 pm
Location: Abilene, TX

Re: 99---> 03 o2 Sensor discrepancies!

Postby tapakidney » Mon Aug 29, 2011 4:10 pm

Bah, I am so ignorant about this stuff. What am I looking for exactly in those pictures? And if I AM Cali spec, my car is running weaker because of it???
tapakidney
Just Licensed SolaraGuy
 
Posts: 5
Joined: Thu Oct 16, 2008 3:21 pm

Re: 99---> 03 o2 Sensor discrepancies!

Postby alexsinclaire » Wed Nov 09, 2011 5:00 pm

there should be a sign under your hood at the front, on the bottom it will say whether its federal and canada or cali spec.
alexsinclaire
Just Licensed SolaraGuy
 
Posts: 5
Joined: Wed Nov 09, 2011 4:31 pm

Re: 99---> 03 o2 Sensor discrepancies!

Postby Jaydo » Thu Oct 24, 2013 8:32 am

Hi Guys, I realize this post is kinda old but I'm up against the same thing with a different twist. I drive a 99 California car, but I now live in Colorado and I doubt I will ever have the car registered in Cali again. My CEL came on with P0135 (Bank 1 Sensor 1), and AutoZone told me that either the 234-4622 or the 234-9009 would work, but the $70 price difference makes me wonder what the difference is.

Also I've noticed that there are sensors out there for $60-$80 bucks that are for non-Cali emissions. Since I don't have get Cali emissions anymore WILL the non-Cali systems work in my car without damaging the system? I wish I knew more about the electronic stuff but I'm still trying to sort it all out.

Thanks.
Jaydo
Just Licensed SolaraGuy
 
Posts: 5
Joined: Mon Feb 04, 2013 9:07 pm

Return to Toyota Solara OEM

Who is online

Users browsing this forum: No registered users and 1 guest