[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSD/4.0/DST' instead
[phpBB Debug] PHP Notice: in file /viewtopic.php on line 988: getdate(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSD/4.0/DST' instead
SolaraGuy.com • View topic - P0171 CEL
Stock talk about Solara

P0171 CEL

P0171 CEL

Postby mightymouse402 » Sun Mar 02, 2014 11:14 pm

Hello all,

Haven't posted/been on here in a while. Honestly don't even know if anybody will respond but let's give it the old college try. I have been having a CEL with P0171 code for the last few months. I've changed one of my O2 sensors before the catalytic and I've just recently changed the MAF sensor too. The CEL will clear for a few days at a time, but when I go on long drives that's when it comes on. I've spent more than 300 bucks trying to fix this and the same darn CEL still keeps on popping up. I changed those parts because that's what I seemed to be finding was the problem in other online forums. Any helpful responses would be greatly appreciated. Thanks!

I have a 1999 Toyota Solara that's pretty much stock with the exception of an Injen intake with the CAI extension.
That's what she said...

Image
User avatar
mightymouse402
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 284
Joined: Fri Jul 11, 2008 6:48 pm
Location: Los Angeles, CA

Re: P0171 CEL

Postby Gregtrd » Mon Mar 03, 2014 10:09 am

You're trouble shooting in the dark, you need a scan tool to check your fuel trims and check for leaks.
The Fastest Camry in Socal
366whp / 427wtq @10.5psi
Image
User avatar
Gregtrd
SolaraGuy Street Racer
SolaraGuy Street Racer
 
Posts: 1114
Joined: Thu Jul 28, 2005 2:14 am
Location: Fontana

Re: P0171 CEL

Postby dinoxor » Mon Mar 03, 2014 9:10 pm

I had the same problem as well and was able to semi-diagnosed it to be my Injen intake.

If you connect the hose in the front that goes from your pcv/blow-by (I'm still not too sure what it's called) to your intake then there is a SLIGHT possibility that the oil that passes by may foul your MAFS and will make your reading all wonky.

You can use my thread as a reference: http://solaraguy.com/viewtopic.php?f=2&t=53939

I ended up with this : http://solaraguy.com/viewtopic.php?f=2&t=54007
I know it's ghetto rigged, but once I have sufficient funding, I'll implement a proper oil catch can.

After 2 years, the codes appear MUCH less frequently.
If a code does pop up, usually during WOT, it would disappear the next time I start the car.

Hope this helps and good luck.
User avatar
dinoxor
SolaraGuy Driver
SolaraGuy Driver
 
Posts: 439
Joined: Wed Jun 02, 2010 6:04 pm
Location: Garland, TX

Return to Toyota Solara OEM

Who is online

Users browsing this forum: No registered users and 3 guests